Atualizações Tecnológicas

Loading...

Pesquisar

Carregando...

segunda-feira, 28 de fevereiro de 2011

RESOLUÇÃO 13ª EXERCICIO DA LISTA

13. Escreva um programa para ler o raio de um circulo, calcular e escrever a sua área. (pR²)
Entrada: raio de um circulo
Saída: área do circulo
Calculo: área= PI*(raio²)
//Calcular a área de um circulo
Variaveis
area, raio: real
inicio
escreva (“Digite o raio do circulo: “)
leia (raio)
se raio > 0 entao
area <- pi*(raio^2)
escreva (“A area do circulo de raio: “,raio,”é”,area)
fimse
se raio <=0 entao
escreva (“Raio não pode ser nulo ou negativo.”)
fimse
fimalgoritmo

RESOLUÇÃO 12ª EXERCICIO DA LISTA


12.O custo ao consumidor de um carro novo é a soma do custo de fábrica com a percentagem do distribuidor e dos impostos (aplicados, primeiro os impostos sobre o custo de fábrica, e depois a percentagem do distribuidor sobre o resultado). Supondo que a percentagem do distribuidor seja de 28% e os impostos 45%. Escrever um algoritmo que leia o custo de fábrica de um carro e informe o custo ao consumidor do mesmo.

Entrada: Um valor
Saida: Um valor
Calculo: valor+28%de valor+45%de valor
//Valor do um carro vendido na concesionaria a parti do valor de fabrica

variaves
              valor,porcen_distribuidor,impostos:real
inicio
         escreva("Valor do automovel na fabrica: ")
         leia (valor)
         porcen_distribuidor<-(valor*0.28)+valor
         impostos<-(porcen_distribuidor*0.45)+porcen_distribuidor
         escreva("Valor do automovel: ",impostos)
fimalgoritmo

RESOLUÇÃO 11ª EXERCICIO DA LISTA


11.Faça um algoritmo que receba o preço de custo de um produto e mostre o valor de venda. Sabe-se que o preço de custo receberá um acréscimo de acordo com um percentual informado pelo usuário.

Entrada: 2 valores
Saida: 1 valor
Calculo: Custo+Porcentagem de Custo
//Lucro de Venda

variaveis
               custo,ganho,porcentagem:real
inicio
         escreva ("Preço de Custo do Produto: ")
         leia (custo)
         escreva ("Porcentagem de Ganho sobre o Produto: ")
         leia (ganho)
         porcentagem<-ganho/100
         escreva ("Valor de Venda: ",(porcentagem*custo)+custo)
fimalgoritmo

sábado, 26 de fevereiro de 2011

RESOLUÇÃO 10ª EXERCICIO DA LISTA

10.A Loja Mamão com Açúcar está vendendo seus produtos em 5 (cinco) prestações sem juros. Faça um algoritmo que receba um valor de uma compra e mostre o valor das prestações.
 
alforitmo "Valor de Prestações"
//Entrada: Valor da Compra
//Saida: Valor das Parcelas
//Cálculo: Produto/5
//Parcelamento de Produto
variaveis:
             valor_compra:real
inicio
        escreva ("Digite o valor da compra: ")
        leia (valor_compra)
        escreva ("Valor da Prestação: ",valor_compra/5)
fimalgoritmo

RESOLUÇÃO 9ª EXERCICIO DA LISTA

9.Faça um algoritmo que receba um valor que foi depositado e exiba o valor com rendimento após um mês.
Considere fixo o juro da poupança em 0.70% a. m.
 
alforitmo "Poupanca"
//Entrada: Valor Depositado
//Saida: Rendimento + Depoisito
//Cálculo: Deposito + 0.70% do deposito
//Rendimento da poupanca
variaveis:
             desposito:real
inicio
       escreva ("Valor Despositado: ")
       leia (deposito)
       escreva ("Seu Rendimento: ",(deposito*0.007)+depoisito)
fimalgoritmo
 
 
obs:
     Para qualquer cálculo de porcentagem divi-se a porcentagem referenta por 100
     ou seja 0.70/100 = 0,007 e à multiplica pelo valor ao qual se deseja tirar a porcentagem! 

RESOLUÇÃO 8ª EXERCICIO DA LISTA

8.Elaborar um algoritmo que efetue a apresentação do valor da conversão em real (R$) de um valor lido em dólar (US$). O algoritmo deverá solicitar o valor da cotação do dólar e também a quantidade de dólares disponíveis com o usuário.
 
 alforitmo "Concersão de moeda"
//Entrada: Temperatura em Celsius
//Saida: Temperatura em Farenheit
//Cálculo: dolar * cotacao
//Converter de dolar em real
variaveis:
              dolar, cotacao :real
inicio
       escreva ("Quantidade de dolar a converter: ")
       leia (dolar)
       escreva ("Cotação do dolar: ")
       leia (cotacao)
       escreva ("Quantidade de dolar convertido para real: ", dolar*cotacao)
fimalgoritmo

RESOLUÇÃO 7ª EXERCICIO DA LISTA

7. Ler uma temperatura em graus Celsius e apresentá-la convertida em graus Fahrenheit. A fórmula de conversão é: F=(9*C+160) / 5, sendo F a temperatura em Fahrenheit e C a temperatura em Celsius.
 
alforitmo "Conversão de Temperatura"
//Entrada: Temperatura em Celsius
//Saida: Temperatura em Farenheit
//Cálculo: F=(9*c+160)/5
//Converter temperatura de Celsius para Fahrenheit
variaveis:
             celsius: real
inicio
        escreva ("Temperatura em Celsius: ")
        leia (celsius)
        escreva ("Temperatura em Fahrenheit: ",(9*celsius+160)/5)
fimalgoritmo

quinta-feira, 24 de fevereiro de 2011

RESOLUÇÃO 6ª EXERCICIO DA LISTA

6.Ler dois valores para as variáveis A e B, e efetuar as trocas dos valores de forma que a variável A passe a possuir o valor da variável B e a variável B passe a possuir o valor da variável A. Apresentar os valores trocados.
 
alforitmo "Troca de Valores"
//Entrada: Dois Valores
//Saida: Valores Trocados
//Cálculo: Inversão de Valores
//Troca de Valores entre variaveis
variaveis
            a,b,c:real
inicio
       escreva ("O valor de A: ")
       leia (a)
       escreva ("O valor de B: ")
       leia (b)
       c<-a
       a<-b
       b<-c
       escreval ("O valor de A: ")
       escreva ("O valor de B: ")
fimalgoritmo
 
Lembrando que temos que ter 3 variaveis para que uma haja como variavel de armazenamento, ou seja, para evitar que o valor original de a se perca é necessário associar a uma outra variável (denominada usualmente de variável auxiliar) tal valor, estabelecer uma associação de a com o valor em b e, por último, associar b ao valor "salvo" na variável auxiliar. Assim sendo, uma forma correta de efetuar a troca é:
  • leia a e b
  • aux <- a
  • a <- b
  • b <- aux
  • apresente a e b

RESOLUÇÃO 5ª EXERCICIO DA LISTA

5.Escrever um algoritmo que leia o nome de um aluno e as notas das três provas que ele obteve no semestre. No final informar o nome do aluno e a sua média (aritmética).
alforitmo "Media do aluno"
//Entrada: Notas semestrais
//Saida: Média
//Cálculo: Notas divididas pelo numero de semestres
//Media do aluno em 3 semestres
variaveis
             nome:caractere
             nota1,nota2,nota3:real
inicio
       escreva ("Nome do Aluno: ")
       leia (nome)
       escreva ("Nota 1ª Semestre: ")
       leia (nota1)
       escreva ("Nota 2ª Semestre: ")
       leia (nota2)
       escreva ("Nota 3ª Semestre: ")
       leia (nota3)
       escreva ("Aluno: ",nome,(nota1+nota2+nota3)/3)
fimalgoritmo

RESOLUÇÃO 4ª EXERCICIO DA LISTA

4.Escrever um algoritmo que leia o nome de um vendedor, o seu salário fixo e o total de vendas efetuadas por ele no mês (em dinheiro). Sabendo que este vendedor ganha 15% de comissão sobre suas vendas efetuadas, informar o seu nome, o salário fixo e salário no final do mês.
 
alforitmo "Salario de um Funcionario"
//Entrada: Nome do Funcionario e Dois Valores
//Saida: Nome Salario e Comissão
//Cálculo: Salario + 15% de Comissão sobre vendas
//Rendimento de um funcionario em um mês
variaveis
             nome:caractere
             salario, vendas, comissao:real
            
inicio
 //Seção de Comandos
       escreva ("Nome do Vendedor: ")
       leia (nome)
       escreva ("Salario Fixo: ")
       leia (salario)
       escreva ("Total em Vendas ")
       leia (vendas)
       comissao<-vendas*0.15
       escreval ("Vendedor: ",nome)
       escreval ("Salario Fixo: ",salario)
       escreval ("Salario Total: ",salario+comissão)
fimalgoritmo

RESOLUÇÃO 3ª EXERCICIO DA LISTA

3.Escrever um algoritmo para determinar o consumo médio de um automóvel sendo fornecida a distância total
percorrida pelo automóvel e o total de combustível gasto.
 
alforitmo "Consumo médio de um automóvel"
//Entrada: Dois Valores
//Saida: Média
//Cálculo: num1/num2
//Consumo de combustivel de um automóvel
variaveis
             num1,num2:real
 
inicio
//Seção de Comandos
       escreva ("Quilometragem: ")
       leia (num1)
       escreva ("Comsumo: ")
       leia (num2)
       escreva ("O consumo médio é ", num1/num2)
fimalgoritmo

RESOLUÇÃO 2ª EXERCICIO DA LISTA


2.Faça um algoritmo que receba dois números e ao final mostre a soma, subtração, multiplicação e a divisão dos números lidos.

alforitmo "Soma, Subtração, Multiplicação e Divisão de 2 Numeros"
//Entrada: Dois Valores
//Saida: Resultado da Soma, Subtração, Multiplicação e Divisão de 2 Numeros
//Cálculo: num1+num2,num1-num2,num1*num2,num1/num2
//Fazer as quatro operações utilizando duas variaveis
variaveis
            num1,num2:real

inicio
//Seção de Comando
        escreva ("Digite o 1ª numero: ")
        leia (num1)
        escreva ("Digite o 2ª numero: ")
        leia (num2)
        escreval ("A soma é ",num1+num2)
        escreval ("A Subtração é ",num1-num2)
        escreval ("A Multiplicação é ",num1*num2)
        escreval ("A Divisão é ",num1/num2)
fimalgoritmo

terça-feira, 22 de fevereiro de 2011

RESOLUÇÃO 1ª EXERCICIO DA LISTA

1. Faça um algoritmo que receba dois números e exiba o resultado da sua soma.

 algoritmo "Soma de Valores"
//Entrada: Dois Numeros Inteiros
//Saida: O Resultado da Soma de Dois Numeros
//Calculo: num1+num2

//Soma de Dois Valores
varariaveis

                 num1,num2: inteiro


inicio
// Seção de Comandos
        escreva ("Digite o 1ª numero: ")
        leia (num1)
        escreva ("Digite o 2ª numero: ")
        leia (num2)
        escreva ("O resultado da Soma dos 2 valores é ",num1+num2)
fimalgoritmo

PRIMEIRO POST

ALUNO 1ª SEMESTRE SITEMAS DE INFORMAÇÃO DA FACULDADE ESTÁCIO ATUAL

NESTE BLOG PRETENDO POSTAR OS EXERCICIOS RESOLVIDOS EM SALA DE AULA DE ALGORITMOS E PROGRAMAÇÃO!

ESPERO INTERAÇÃO DE TODOS PARA QUE POSSAMOS TIRAR NOSSAS DÚVIDAS E ATÉ MESMO ENCONTRAR FORMAS MAIS FÁCEIS DE FAZER!

FIQUEM A VONTADE PARA DAR SUGESTÕES E COMENTARIOS!

ESPERO QUE POSSAMOS APRENDER JUNTOS!

POR MAIS QUE NO INICIO SEJA ALGO MUITO BÁSICO VAMOS EVOLUIR NAS QUESTÕES COM O PASSAR DO TEMPO!

Seguidores